Laggy players

  • Everytime I play I run on 10fps or 20fps if I am lucky but everytime I play it seems like other players are just teleporting around everywhere and I cant shoot them right.
    Any help?

  • I have some suggestions.
    Firstly, turn off ragdolls and blood. It reduces parts in the world and helps lag quite a bit.
    Close out any other tabs you have apart from roblox.
    Lower your ingame graphics. (I do this, and I normally keep them on 3)
    If you're really desperate, you can remove your textures to significantly reduce lag. Tutorial on how to do so >

    Also please note that you shouldn't even try to use an FPS unlocker. If your device can't even hit 60 fps, it won't go any way past that.

  • flu_ffy I have to keep my graphics set to 2. If I do 3, it instantly lags roblox to the point where I can't even move.

  • @TheLastMan
    Oh that sucks.

  • flu_ffy I know. It really sucks on long maps, as it actually limits how far you can see, sometimes completely ruining any sniping I could do.

  • Global Moderator

    Disable the gun models in the lobby. Those gun models are always there, and it affects your frame-rate a quite a significant scale. For those on higher-performance PCs. Use an FPS Unlocker and notice the difference between with them enabled, and when they're not enabled.

    In addition, a lot of users who have lower-performance PCs tend to delete all the textures from the Roblox file. It's worth noting when you do this, everytime Roblox updates, which is usually always weekly. You'll have to redo the deleting of the textures.

    Elsewise, other options include the ones that flu_ffy mentioned above.

  • I have tried and honestly I think I need a new laptop because my average fps is still 10 though if I set my graphics level to 1 and I disabled all rag dolls/blood/particles , so that's a big yikes for me, I'll just stop playing phantom forces for now.
    Thanks for the help though I appreciate it.

  • Developer

    Void What is your platform?

Log in to reply